Preparing report...

Report for github.com/awesee/leetcode

(v1.6.6)

A+    Excellent!    Found 10 issues across 2011 files

Tweet

gofmt100%

Gofmt formats Go programs. We run gofmt -s on your code, where -s is for the "simplify" command

No problems detected. Good job!


go_vet100%

go vet examines Go source code and reports suspicious constructs, such as Printf calls whose arguments do not align with the format string.

No problems detected. Good job!


gocyclo99%

Gocyclo calculates cyclomatic complexities of functions in Go source code. The cyclomatic complexity of a function is calculated according to the following rules: 1 is the base complexity of a function +1 for each 'if', 'for', 'case', '&&' or '||' Go Report Card warns on functions with cyclomatic complexity > 15.


golint99%

Golint is a linter for Go source code.

    • problems/min-stack/min_stack.go
    • Line 3: warning: exported type MinStack should have comment or be unexported (golint)
    • Line 7: warning: comment on exported function Constructor should be of the form "Constructor ..." (golint)
    • Line 12: warning: exported method MinStack.Push should have comment or be unexported (golint)
    • Line 12: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • Line 20: warning: exported method MinStack.Pop should have comment or be unexported (golint)
    • Line 20: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • Line 24: warning: exported method MinStack.Top should have comment or be unexported (golint)
    • Line 24: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • Line 28: warning: exported method MinStack.GetMin should have comment or be unexported (golint)
    • Line 28: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • problems/number-of-recent-calls/number_of_recent_calls.go
    • Line 5: warning: exported type RecentCounter should have comment or be unexported (golint)
    • Line 9: warning: exported function Constructor should have comment or be unexported (golint)
    • Line 13: warning: exported method RecentCounter.Ping should have comment or be unexported (golint)
    • Line 13: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • problems/range-sum-query-immutable/range_sum_query_immutable.go
    • Line 3: warning: exported type NumArray should have comment or be unexported (golint)
    • Line 7: warning: exported function Constructor should have comment or be unexported (golint)
    • Line 17: warning: exported method NumArray.SumRange should have comment or be unexported (golint)
    • Line 17: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • problems/design-linked-list/design_linked_list.go
    • Line 5: warning: exported type MyLinkedList should have comment or be unexported (golint)
    • Line 9: warning: comment on exported function Constructor should be of the form "Constructor ..." (golint)
    • Line 14: warning: comment on exported method MyLinkedList.Get should be of the form "Get ..." (golint)
    • Line 15: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • Line 26: warning: comment on exported method MyLinkedList.AddAtHead should be of the form "AddAtHead ..." (golint)
    • Line 27: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • Line 31: warning: comment on exported method MyLinkedList.AddAtTail should be of the form "AddAtTail ..." (golint)
    • Line 32: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • Line 36: warning: comment on exported method MyLinkedList.AddAtIndex should be of the form "AddAtIndex ..." (golint)
    • Line 37: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • Line 49: warning: comment on exported method MyLinkedList.DeleteAtIndex should be of the form "DeleteAtIndex ..." (golint)
    • Line 50: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • problems/design-hashset/design_hashset.go
    • Line 3: warning: exported type MyHashSet should have comment or be unexported (golint)
    • Line 7: warning: comment on exported function Constructor should be of the form "Constructor ..." (golint)
    • Line 12: warning: exported method MyHashSet.Add should have comment or be unexported (golint)
    • Line 12: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • Line 16: warning: exported method MyHashSet.Remove should have comment or be unexported (golint)
    • Line 16: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • Line 20: warning: comment on exported method MyHashSet.Contains should be of the form "Contains ..." (golint)
    • Line 21: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • problems/design-hashmap/design_hashmap.go
    • Line 3: warning: exported type MyHashMap should have comment or be unexported (golint)
    • Line 7: warning: comment on exported function Constructor should be of the form "Constructor ..." (golint)
    • Line 12: warning: comment on exported method MyHashMap.Put should be of the form "Put ..." (golint)
    • Line 13: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • Line 17: warning: comment on exported method MyHashMap.Get should be of the form "Get ..." (golint)
    • Line 18: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)
    • Line 25: warning: comment on exported method MyHashMap.Remove should be of the form "Remove ..." (golint)
    • Line 26: warning: receiver name should be a reflection of its identity; don't use generic names such as "this" or "self" (golint)

license100%

Checks whether your project has a LICENSE file.

No problems detected. Good job!


ineffassign100%

IneffAssign detects ineffectual assignments in Go code.

No problems detected. Good job!


misspell100%

Misspell Finds commonly misspelled English words

No problems detected. Good job!